Docusign outage impacting eSign customers
Incident Report for EngagedMD
Resolved
Docusign has implemented a fix to resolve the incident.
Posted Feb 27, 2024 - 12:32 EST
Identified
Docusign is having a major outage that impacts our eSign customers. We are monitoring the situation for a resolution.
Posted Feb 27, 2024 - 12:24 EST
This incident affected: EngagedMD Legacy Platform (eSign).