Degraded performance in our eSign workflows
Incident Report for EngagedMD
Resolved
This incident has been marked as resolved by Docusign.
Customers should expect delays on status updates for assignments as Docusign works to clear the backlog,
Posted Apr 30, 2024 - 13:58 EDT
Update
Docusing is recovering, our teams will continue to monitor for any signs of degradation. Customers should expect delays with envelope statuses as Docusign continues to clear through the backlog.
Posted Apr 30, 2024 - 13:09 EDT
Update
We are continuing to monitor this issue as Docusign is taking steps to recover.
Posted Apr 30, 2024 - 12:12 EDT
Monitoring
We are currently experiencing degraded performance in our eSign workflows due to a Docusign incident. Our team is monitoring the situation closely and will keep you updated.
Posted Apr 30, 2024 - 11:11 EDT
This incident affected: EngagedMD Legacy Platform (eSign) and Care Experience Platform (eSign).