Outage on April 16, 2025

Incident Report for EngagedMD

Resolved

We've resolved the incident and restored operation.
Posted Apr 16, 2025 - 17:10 EDT

Monitoring

We've implemented and rolled out a fix, monitoring the system for stability.
Posted Apr 16, 2025 - 17:05 EDT

Identified

The issue has been found, we are implementing a fix.
Posted Apr 16, 2025 - 16:50 EDT

Investigating

We are currently investigating the issue.
Posted Apr 16, 2025 - 16:38 EDT
This incident affected: Care Experience Platform (Patient Portal, eLearn, eSign, API, Staff Portal).