eSign workflow is experiencing delays due to a Docusign outage.

Incident Report for EngagedMD

Resolved

Docusign has resolved this incident.
Posted Feb 05, 2025 - 20:36 EST

Investigating

Our team is actively investigating the issue and will have an update soon.
Posted Feb 05, 2025 - 14:50 EST
This incident affected: EngagedMD Legacy Platform (eSign) and Care Experience Platform (eSign).