Staff Application and Patient Portal Unavailable - 15 Minute Outage Expected
Incident Report for EngagedMD
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 11:14 EDT
Investigating
We are currently investigating this issue.
Posted Sep 15, 2023 - 11:04 EDT
This incident affected: EngagedMD Legacy Platform (Patient Portal, Staff Portal).