Email Delivery - Outdated Patient Email Delivery
Incident Report for EngagedMD
Resolved
This issue has been resolved - we have confirmed that only a small subset of system testing emails were re-delivered, and no real patients were contacted by the inadvertent email delivery.
Posted Feb 24, 2023 - 11:23 EST
Investigating
EngagedMD's email partner is experiencing issues as they apply a patch on their systems - this has resulted in outdated email invitations being sent to patients.

Patients from 2+ years ago may receive an invitation to log into EngagedMD and check their educational content or forms.
Please note: There are no new assignments, and no usage accrual for those patients or related emails. The email processor has re-sent old emails.
If any previous patients reach out about new assignments, please let them know it was likely just a system error.

We apologize for this inconvenience. - The EngagedMD team is investigating methods to prevent the processor from continuing to send any more inadvertent notifications.
Posted Feb 24, 2023 - 11:01 EST
This incident affected: EngagedMD Legacy Platform (Patient Portal).