Docusign Degraded Performance

Incident Report for EngagedMD

Resolved

Docusign has reported that systems have returned to operational status. Please reach out to us at support@engagedmd.com if you need further assistance.
Posted Oct 21, 2025 - 10:27 EDT

Identified

We are aware of an issue currently affecting sending and/or completing signing of documents due to an 3rd party issue with a public cloud provider that is effecting Docusign. We are monitoring the issue and will provide further updates as we receive them from Docusign.

Thank you for your patience.
Posted Oct 20, 2025 - 12:46 EDT
This incident affected: Care Experience Platform (eSign).