Slowness reported across patient and staff portals
Incident Report for EngagedMD
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 13:42 EST
Update
We are conducting a restart and expect service to return in the next 15 minutes
Posted Nov 15, 2023 - 13:18 EST
Monitoring
Some clients are reporting slow page load times. We are monitoring the issue and will take further action as needed.
Posted Nov 15, 2023 - 11:35 EST
This incident affected: EngagedMD Legacy Platform (Patient Portal, Staff Portal).