API Timeout & Slowness
Incident Report for EngagedMD
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 11:54 EST
Update
The issue has been resolved & all portals are accessible per normal. Our team is monitoring performance to ensure access is not disrupted again. Thank you for your patience today.
Posted Feb 23, 2023 - 16:22 EST
Update
Please expect a 15 minute outage across all EngagedMD portal as our teams refresh the systems and resolve this issue.

We will keep updates coming once the system has returned and is accessible.
Posted Feb 23, 2023 - 16:18 EST
Investigating
We are detecting disturbances in our legacy API connectivity to various client EMR's - resulting in a 504 Connectivity Error for some EMR integration users. Users connecting to EngagedMD via their EMR may experience a partial outage and error message.
Users that are accessing portals directly will experience application slowness until this has been resolved.

Our team is investigating the cause of this disturbance, and will be working to resolve the issue.

EngagedMD also offers a new API endpoint for EMR integrations - this endpoint is unaffected by this partial outage. Please contact your EMR to have them reconnect to EngagedMD's upgraded API endpoint - which offers better resiliency in situations like this.

_______________________
Normal activities can be performed by accessing your EngagedMD portal directly (Note: the portal is experiencing slow load times).
Some activities that can be performed directly via your EngagedMD portal: assignment of new modules, creation of new patients, and signing forms.

Visit [your portal name].engagedmd.com to login, or reference an EngagedMD email link to be redirected to your portal.
Posted Feb 23, 2023 - 10:04 EST
This incident affected: EngagedMD Legacy Platform (API, Staff Portal).