We are experiencing delays in our platform, our team is currently investigating.
Incident Report for EngagedMD
Resolved
The incident has been resolved.
All systems are Operational
Our teams will continue to monitor performance closely.
Posted Apr 19, 2024 - 12:16 EDT
Update
All systems are currently operational, we are still experiencing slowness in certain parts of the Staff Portal.
Please stay tuned for updates as we work to resolve this as quickly as possible.
Posted Apr 19, 2024 - 11:38 EDT
Update
Systems are currently stable, we are continuing to monitor performance in the Staff Portal
Posted Apr 19, 2024 - 11:07 EDT
Update
All systems are currently operational, we are investigating degraded performance in our Staff Portal.
Posted Apr 19, 2024 - 10:35 EDT
Investigating
We are currently investigating this issue.
Posted Apr 19, 2024 - 10:26 EDT
This incident affected: Care Experience Platform (Patient Portal, eLearn, eSign, API, Staff Portal).